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Veritone Voice API

Setting up

To use the API connection, you will need a Veritone account and API key. Please contact sales via

the Veritone website to talk to a sales representative.

API key and integration

Once you have your API key from Veritone, simply copy the API key into your clipboard.

Follow the steps to integrate into VoiceQ:

1. Open the VoiceQ application.

2. Create or open a project you wish to work on.

3. Select “Window>External service configuration…”

4. Select 'Veritone’ in the Text-to-speech" drop-down menu.

5. Select the ‘Veritone' tab.

6. In the API key text box, paste your API key from Veritone.

https://www.veritone.com/


Selecting Voices and Clip Management

Once you have added your API key from Veritone, follow the next steps to add voices and

manage clips:

1. select a Veritone project you have created online.

a. If your project is not visible, select ‘Reload.'

2. Once you have your project selected, press "Voice management."

a. It may not be supported if you do not see voices in your selected language. If so,

you must add a supported language or change the currently selected language to

one from the list of under-supported languages.

3. Now assign voices to the characters you wish to use Veritone within the project.

4. Once done, you may select 'Done'

5. Back in the External Services window, you will also see the following options:

a. Voice management: This is the window you can use to select voices for each

project character.

b. Clip management: This window shows the user which audio clips are created on

Veritone. This is good if you can not download a clip, as you can see if it is still

processing online.

c. Convert clips to audio when registering: Select this to convert the audio clips

from Veritone to m4a, WAV PCM for the studio.

d. Convert (Dropdown): You can select which files to convert when sourcing from

Veritone servers.



Generating voices

Now that you have assigned voices and become familiar with the UI - let's add voices.

1. Select a line you wish to generate a voice for in the script view

2. Select "Window>Local Recording."

3. In the Recording window, you will see two options:

a. Register clips: This option sends the text and voice selection options to the

Veritone servers to create clips online.

b. Generate voices: This option calls the files from Veritone servers to the

application window.

4. Select the option "Register clips" and wait until the process has been completed.

5. select "Generate voices" and wait - you should see the Take section.

6. Select the following line and repeat the process - Note: If you select multiple lines in the

script window, you can select register clips, generate batch export, and import voice files

from Veritone servers.

Premium voices

Premium voices will allow the user to use Prosody SSML. This will allow lines to have a max

duration to follow. Please contact your Veritone sales agent to access Premium Voices on your

account to take advantage of this feature. (VoiceQ 7.0.3 or higher required)



Exporting AAF

Now that you have the voice clips done in VoiceQ, select the takes you to wish to export.

1. Select the takes you wish to export in the Local recording window.

a. Note: Before creating an AAF playlist file, you must review each line to confirm the

correct audio.

2. Select "Export…"

3. Select "Embed audio files" - You may use relative time if you want the start positions to be

exact (this is advised)

4. Name your AAF file and select "Export…."

5. Choose the location to save and select 'Save.'

\

The AAF file will be able to be imported into Pro Tools and other DAW applications where AAF is

acceptable.



Using your Veritone AAF in Pro Tools

Importing your AAF (Advanced Authoring Format) file into Pro Tools is straightforward. Here's a

step-by-step guide to help you accomplish it:

1. Launch Pro Tools: Open the Pro Tools application on your computer. Ensure that you have

the latest version installed for optimal compatibility.

2. Create a New Session (Optional): If you want to import the AAF file into a new session, go

to the "File" menu and select "New Session." Configure the session settings according to

your requirements.

3. Open an Existing Session (Optional): If you wish to import the AAF file into an existing

session, go to the "File" menu and select "Open Session." Locate and open the desired

session file.

4. Access the Import Menu: Once a session opens in Pro Tools, go to the "File" menu and

select "Import."

5. Choose the AAF File: In the Import window, navigate to the location where the AAF file is

stored. Select the AAF file and click "Open" to proceed.

6. Configure Import Settings: The Import Session Data window will appear, allowing you to

customize the import settings.

7. Select Tracks to Import: In the Import Session Data window, you'll see a list of tracks set

by the Voices you exported from VoiceQ in the AAF file. Choose the tracks you want to

import by selecting the corresponding checkboxes. You can import all tracks or only

specific ones based on your needs.

8. Adjust Options: The Import Session Data window also provides additional options for

handling conflicts, selecting target locations, and modifying import behaviour. Adjust

these settings according to your preferences.

9. Preview and Import: Once you have finalized the import settings, click the "Preview"

button to see how the imported session will look in Pro Tools. Review the preview and

make any necessary adjustments. When satisfied, click "OK" to initiate the import process.

10. Monitor the Import Progress: Pro Tools will begin importing the AAF file. You can monitor

the progress in the Progress Window, which displays the import status.

11. Verify Imported Session: After the import is complete, Pro Tools will display a confirmation

message. Take a moment to verify that the session has been imported correctly, including

the audio, video, edits, and metadata.



Importing media into Pro Tools

Importing a video file into Pro Tools will allow you to synchronize your audio work with visual

content.. Here's a step-by-step guide to help you import a video file into Pro Tools:

1. Access the Import Menu: Once you have a session open in Pro Tools, go to the "File"

menu and select "Import" followed by "Video."

2. Choose the Video File: In the Import Video window, navigate to the location where the file

is stored. Select the video file and click "Open" to proceed.

3. Specify Video Import Settings: Pro Tools will present you with the Video Import Settings

window, where you can configure various options related to the video import process.

4. Select Video Track: Choose the desired video track from the dropdown menu in the

Video Import Settings window if your video file contains multiple video tracks. If there is

only one video track, it will be automatically selected.

5. Set Frame Rate: Enter the frame rate of the video file in the Frame Rate field. If you're

unsure of the frame rate, check it using external video players or editing software.

6. Adjust Synchronization Options: In the Video Import Settings window, you'll find options to

synchronize the video with your session. You can import the video with a specific starting

timecode or use other synchronization methods based on your needs.

7. Select Video Conversion Quality (Optional): If necessary, you can adjust the video

conversion quality by selecting a preset from the Quality dropdown menu in the Video

Import Settings window. The available options may vary based on your Pro Tools version.

8. Adjust Options and Preferences: The Video Import Settings window may have additional

options and preferences you can customize based on your requirements. Review and

modify these settings as needed.

9. Preview and Import: Once you have configured the video import settings, click the

"Preview" button to preview how the video will appear in Pro Tools. Review the preview

and make any necessary adjustments. When satisfied, click "OK" to initiate the import

process.

10. Monitor the Import Progress: Pro Tools will start importing the video file. You can monitor

the progress in the Progress Window, which displays the import status.

11. Verify Imported Video: Pro Tools will display a confirmation message after the import is

complete. Take a moment to verify that the video has been imported correctly and it is

synchronized with your session.



Exporting Veritone audio from Pro Tools for delivery

Exporting a media file from Pro Tools allows you to create a standalone audio file that can be

shared, transferred, or used in other applications. Here's a step-by-step guide to help you export

a media file from Pro Tools:

1. Complete your Project: Ensure that your Pro Tools project is complete and ready for

export. Make any necessary edits, adjustments, or mixing before proceeding with the

export.

2. Select the Section to Export: If you only want to export a specific section of your project,

use the selection tools in Pro Tools to choose the desired range. Alternatively, skip this

step if you want to export the entire project.

3. Set the Session Start and End Points (Optional): In the Pro Tools transport bar, locate the

Session Start and End markers. Adjust these markers if you want to define a specific

portion of the session to be exported. If you want to export the entire session, ensure that

the markers encompass the entire length of your project.

4. Configure Export Settings: Go to the "File" menu and select "Export" followed by "Audio

Mixdown." The Export Audio Mixdown window will appear, allowing you to configure the

export settings.

5. Choose File Format and Type: In the Export Audio Mixdown window, select the desired

file format for your exported media file. Pro Tools supports various formats, including WAV,

AIFF, MP3, and more. Choose the format that best suits your requirements.

6. Specify File Name and Location: Use the "Save As" field to assign a name to the exported

media file. Browse to select where you want to save the file on your computer's storage.

7. Set Sample Rate and Bit Depth: Configure the exported media file's sample rate and bit

depth. Typically, you'll want to match these settings with your session's original sample

rate and bit depth to maintain the highest quality.

8. Choose Mono or Stereo (Optional): If you're working with a multichannel session, decide

whether to export the media file in mono or stereo format. Select the appropriate option

based on your project's needs.

9. Apply Dithering (Optional): Dithering can be used to minimize artefacts when reducing the

bit depth. If necessary, select the desired dithering option from the dropdown menu. Note

that dithering is typically only necessary when exporting to lower-bit depths.

10. Set Normalization (Optional): To normalize the exported media file to a specific peak level,

check the "Normalize" box and enter the desired peak level value. Normalization adjusts

the overall volume of the file to a specified level.



11. Verify Export Settings: Review all the export settings in the Export Audio Mixdown window

to ensure they are accurate and match your requirements.

12. Initiate the Export: Once satisfied with the export settings, click the "OK" button to start

the export process. Pro Tools will process the audio and create the media file based on

your settings.

13. Monitor the Export Progress: Pro Tools will display a progress window indicating the

export status. You can monitor the progress until the export is complete.

14. Verify Exported Media File: After the export is finished, navigate to the location where you

saved the media file. Play the exported file in a media player or import it into another

application to confirm that it has been successfully exported and works as intended.



Supported languages

Veritone voice will only work in a select number of languages - please see the list below:

Language code

AF-ZA DA-DK ES-EC

AM-ET DE-AT ES-ES

AR-AE DE-CH ES-GQ

AR-BH DE-DE ES-GT

AR-DZ EL-GR ES-HN

AR-EG EN-AU ES-MX

AR-IQ EN-CA ES-NI

AR-JO EN-GB ES-PA

AR-KW EN-HK ES-PE

AR-LB EN-IE ES-PR



AR-LY EN-IN ES-PY

AR-MA EN-KE ES-SV

AR-OM EN-NG ES-US

AR-QA EN-NZ ES-UY

AR-SA EN-PH ES-VE

AR-SY EN-SG ET-EE

AR-TN EN-TZ EU-ES

AR-YE EN-US FA-IR

AZ-AZ EN-ZA FI-FI

BG-BG ES-AR FIL-PH

BN-BD ES-BO FR-BE

BN-IN ES-CL FR-CA



BS-BA ES-CO FR-CH

CA-ES ES-CR FR-FR

CS-CZ ES-CU GA-IE

CY-GB ES-DO GL-ES

GU-IN MN-MN TR-TR

FA-IR MR-IN UK-UA

FI-FI MS-MY UR-IN

FIL-PH MT-MT UR-PK

FR-BE MY-MM UZ-UZ

FR-CA NB-NO VI-VN

FR-CH NE-NP ZH-CN

FR-FR NL-BE ZH-HK



GA-IE NL-NL ZH-TW

GL-ES PL-PL ZU-ZA

GU-IN PS-AF

HE-IL PT-BR

HI-IN PT-PT

HR-HR RO-RO

HU-HU RU-RU

HY-AM SI-LK

ID-ID SK-SK

IS-IS SL-SI

IT-IT SO-SO

JA-JP SQ-AL



JV-ID SR-RS

KA-GE SU-ID

KK-KZ SV-SE

KM-KH SW-KE

KN-IN SW-TZ

KO-KR TA-IN

LO-LA TA-LK

LT-LT TA-MY

LV-LV TA-SG

MK-MK TE-IN

ML-IN TH-TH


