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VoiceQ and Digital Audio Workstations 

This guide describes the configurations and procedures used within VoiceQ and Digital 
Audio Workstations and are intended for use by Audio Engineers to understand the 
operation and configuration of both systems. 

During the recording process VoiceQ takes over the role of playing back the movie file from 
Logic Pro X. You can leave the movie file loaded in your Logic Pro X session, but the track 
should be disabled, to avoid competing with the VoiceQ Application. 

 
VoiceQ superimposes the scrolling text on the movie and outputs it via the second 
DVI/HDMI port of your Apple Mac video card (or the external DVI port on laptops). VoiceQ 

uses the Graphics Processing Unit (GPU) and the Memory on the video card to process the 
video, which reduces the load on the CPU of your computer. 

 
VoiceQ will chase and scrub with Logic Pro X while you work in Logic Pro X. VoiceQ also has 
an option to cue Logic Pro X when you select a line in VoiceQ. This will locate the Logic Pro 
X session to the record location for the selected line with an adjustable pre-roll value. 
VoiceQ does not control Logic Pro X in any other way, at this time. 

 
Actual recording of audio and management of playlists still takes place in Logic Pro X using 
your normal process. 

 
Note: In a single computer configuration VoiceQ will work with many other recording 
applications including Pro Tools, Soundtrack and others. Check our website for the correct 
set up instructions and screen shots for these applications. 

 
Note: In a dual computer configuration the Digital Audio Workstation may be any device that 
will output MIDI Time Code (MTC) and/or MIDI Machine Control. 

 
Note: If you experience issues with stopping playback from VoiceQ, we recommend 
that you use the transport controls via Logic Pro. 



3  

Single Machine Setup (using IAC driver) 
 

The Apple Inter Application Communication (IAC) Bus is used to send all MIDI information 
when VoiceQ and Logic Pro X are on the same computer – we refer to this as a Single 
Computer Configuration. 

 
A MIDI interface or Network Session is used when the Digital Audio Workstation (DAW), in 
this case Logic Pro X, and VoiceQ are on separate machines (dual computer configuration). 
If you are using a Dual Computer Configuration you do not need the IAC Bus and can skip 
directly to the next section. 
 
Audio MIDI Setup 

 
1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. 

Launch this app and select Window>Show MIDI Window (Command + 2) from the 
menu to open it. 

 

 
2. Select IAC Driver. Double click it to open the IAC Driver Properties window. 
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3. Add Ports by selecting ‘+’ button and give the port a name. In this example, we 
named it VQ & PT. 

4. Click the checkbox ‘Device is online’ to enable this virtual MIDI device. 

 
Logic Pro X 

 

5. Create a new or open an existing project 

6. Select Logic Pro then preferences and MIDI… 
 

 
 

7. Under the sync tab select the check boxes for transmit locate commands 
8. Close the preferences and select File, Project Settings, Synchronization 
9. Under ‘General’ select the sync mode ‘Internal’ 

 

 
 
 

10. Check the frame-rate and select ‘Auto detect format of MTC’ 
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11. Navigate to the ‘MIDI’ options and use the dropdown to select the IAC Driver 
12. Turn on the clock option. 

 

 
 
 

13. In the second selection choose ‘All’ and MMC checkbox 
14. In the lower section check that both Transmit and Listen are active. 

 
VoiceQ Pro 
 

15. Launch VoiceQ and select VoiceQ>Preferences>Global>DAW… from  VoiceQ main menu. 
 

 
16. Enable Output MMC Port and select the IAC Driver by name. In this example it is 

VoiceQ IAC/MTC. 

 
VoiceQ and Logic Pro X are now ready to communicate through a virtual MIDI device. 
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Dual Machine Setup using Network (RTC-MIDI) 
 

The Dual Computer Configuration is when Logic Pro X and VoiceQ are on separate 
computers with MIDI information sent via the Local Area Network (LAN). 

 
With a Dual Computer Configuration, we can use Apple’s MIDI network feature to send 
MIDI via the Local Area Network. This setup does not require any additional MIDI hardware. 
First configure your LAN (if required) so the 2 machines can communicate and ‘see’ each 
other on the local network. 
Contact your Systems Administrator for assistance if required. 

 
On the computer running Logic Pro X 

 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. 
Launch this app and select Window>Show MIDI Window (Command + 2) from the 
menu to open it. 

 

 

2. Select Network. Double click it to open the MIDI Network Setup window. 
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3. Add a session by selecting ‘+’ button under My Sessions. Enable the session by 
clicking the Enabled check box under Session and name it. We are using the default 
name ‘Session 1’ in this example. 

4. Select ‘Anyone’ from the drop-down list under ‘Who may connect to me:’ section. 

5. Select this Network Session from the first drop down list under the ‘Live routings’ 
section. 

 
On the computer running VoiceQ 

 

1. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. 
Launch this app and select Window>Show MIDI Window (Command + 2) from the 
menu to open it. 

 

 

2. Select Network. Double click it to open the MIDI Network Setup window. 
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3. Add a session by selecting ‘+’ button under My Sessions. Enable the session by 
clicking the Enabled check box under Session. You must give the exact same name 
and port used in Step 3. Again, we are using the default name ‘Session 1’ in this 
example. 

4. Now you can see the Mac that runs Logic Pro X from the Directory list. In our 
example, its name is Yosemite iMac. Select the Mac running Logic Pro X from the 
list. Connect to it by clicking the ‘Connect’ button. 

 
On the computer running Logic Pro X 

 
Logic Pro X 

 

1. Create a new or open an existing project 

2. Select Logic Pro then preferences and MIDI… 
 

 
 

3. Under the sync tab select the check boxes for transmit locate commands 
4. Close the preferences and select ‘File>Project Settings>Synchronization’ 
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5. Under ‘General’ select the sync mode ‘Internal’ 
 

 
 
 

6. Check the frame-rate and select ‘Auto detect format of MTC’ 
7. Navigate to the ‘MIDI’ options and use the dropdown to select the Network connection 
8. Turn on the clock option. 

 

 
 
 

9. In the second selection choose ‘All’ and MMC checkbox 
10. In the lower section check that both Transmit and Listen are active. 
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11. Launch VoiceQ and select VoiceQ>Preferences>Global>DAW… 

from VoiceQ main menu. 

 

12. Enable Output MMC Port and select the Network Session by name. In this 

example it is ‘Session 1’. 

 
VoiceQ and Logic Pro X are now ready to communicate through your network (RTC-MIDI). 

 
Note: RTC-MIDI protocol used for this configuration is stable in most cases, but it does not 

guarantee zero packet loss. The latency and the possibility of packet loss may vary under 

your network conditions. Especially when the network is congested, which may cause the 

latency and packet loss to increase. To account for this, you may use the ‘Latency 

Compensate slider’ in VoiceQ until sync is perfected. 
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Dual Machine Setup using MIDI hardware interfaces 
 

Using separate computers for Logic Pro X and VoiceQ with MIDI information sent via MIDI 
hardware interfaces. 

 
This configuration requires a MIDI hardware interface on both computers, which are 
connected via a MIDI cable. Many AVID hardware boxes like the M-Box 003, Digi 001-003, 
Command 8, Control 24 feature MIDI output ports. 

 
The VoiceQ computer can use any standard USB MIDI interface, with VoiceQ automatically 
recognizing and chasing incoming MIDI timecode when it is set to online/chase mode. 

 
On both computers running Logic Pro X and VoiceQ 

 

1. Connect both computers with the MIDI Device using the appropriate MIDI cables. 
The actual configuration maybe different from the screen shots. 

2. Open MIDI Studio. It is located in Applications/Utilities/Audio MIDI Setup.app. 
Launch this app and select Window>Show MIDI Window (Command + 2) from the 
menu to open it. 
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3. Check all your MIDI interfaces are shown in the windows of both machines. If not, 
click `Rescan MIDI’ button to rescan MIDI ports. In this example, we used USB MS1x1 
MIDI Interface from M-Audio for Logic Pro X machine, and USB Uno MIDI Interface 
from M-Audio for the VoiceQ machine. 

 
On the computer running Logic Pro X 

 
Logic Pro X 

 

1. Create a new or open an existing project 

2. Select Logic Pro then preferences and MIDI… 
 

 
 

3. Under the sync tab select the check boxes for transmit locate commands 
4. Close the preferences and select ‘File>Project Settings>Synchronization’ 
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5. Under ‘General’ select the sync mode ‘Internal’ 
 

 
 
 

6. Check the frame-rate and select ‘Auto detect format of MTC’ 
7. Navigate to the ‘MIDI’ options and use the dropdown to select the ‘MIDI HARDWARE’ 
8. Turn on the clock option. 

 

 
 
 

9. In the second selection choose ‘All’ and MMC checkbox 
10. In the lower section check that both Transmit and Listen are active. 
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On the computer running VoiceQ 
 

1. Launch ‘VoiceQ and select VoiceQ>Preferences…’ from VoiceQ  main menu. 
 

 
2. Enable Output MMC Port and select the MIDI interface connected to the VoiceQ 

machine in this example the USB MS1x1 MIDI 
 

VoiceQ will now chase the incoming MIDI timecode from Logic Pro X through your 
hardware MIDI interface. 

 
VoiceQ will also scrub the video and scroll text in response to the MIDI machine control. 

MIDI Beat clock is used for additional synchronization accuracy. The transport controls 

in VoiceQ can also be used, even when VoiceQ is waiting for external MTC. To have 

VoiceQ chase incoming MTC from Logic Pro X click on the `Chase External Timecode’ 

button in the transport section or use the Quick Key ⌘J. 
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Recording triggered by VoiceQ 
 

1. Configure MIDI connection between Logic Pro X and VoiceQ 

2. Next set pre-roll time settings so both are the same in Logic Pro X and VoiceQ eg. 
3000ms (3.0 seconds) is a common setting. 

 
a. To configure the pre-roll in Logic Pro X, select the recording settings by 

right-clicking the record icon in the top view as shown below. 
 

 
b. Under Recording Settings…. set the Record pre-roll under General 

settings to the desired time as Shown in Figure 1 below. 
 

Note: Logic Pro X only uses seconds for time measurement. 
 

Figure 1. Pre-roll time setting in Logic Pro X 
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c. In VoiceQ, set the Record pre-roll under Global settings to the       same time 
set in Logic Pro X, as shown in Figure 2 below: 

 

 
 

Figure 2. MIDI and Preroll settings in VoiceQ. 

 

3. In Logic Pro X, add an audio track (if required) and enable recording. When 
recording is enabled, the Record Icon flashes red in color. 
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4. In VoiceQ, turn on MIDI chase (MIDI connection) by clicking the icon. 

 

 

Figure 4. VoiceQ MIDI connection icon 
 

5. In VoiceQ, select a line. 

6. Logic Pro X will shift to the selected lines’ start timecode and record with pre-roll 
configured in Logic Pro X and VoiceQ. 

7. Command + Down (or Up) to select next (previous) line and repeat step 6. 
 

Please contact VoiceQ Support if you require further information on how to implement any of 
these configurations. 
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